My Lemmy instance lemmy.cat is not showing URL images of the posts like this example mising image

Same post at lemmy.ml is OK OK

I have something misconfigured so it seems. Any clue?

@nutomic
admin
4edit-23M

Thats most likely a problem with iframely, you can check the logs with:

sudo docker-compose logs -f iframely

Edit: actually all your images seem broken, so check the logs for pictrs as well, and make sure you didnt misconfigure nginx.

@spla
creator
13M

docker-compose logs -f iframely throws one error: iframely_1 | data: cluster.js:33 - error: Forever detected script was killed by signal: SIGKILL iframely_1 | data: cluster.js:33 - error: Script restart attempt #1 and pictrs logs shows no errors

@nutomic
admin
13M

I dont know what that means, but try to restart it. If that doesnt help, check their issue tracker I guess.

@spla
creator
13M

ah, nginx is not happy:

recv() failed (104: Connection reset by peer) while reading response header from upstream, client: X.X.X.X, server: lemmy.cat, request: “GET /iframely/oembed?url=http://www.plataforma-llengua.cat HTTP/2.0”, upstream: “http://0.0.0.0:8061/oembed?url=http://www.plataforma-llengua.cat”, host: “lemmy.cat”, referrer: “https://lemmy.cat/create_post?community_id=16

@nutomic@lemmy.ml I get it working from inside iframely container. I did this:

  • forever stopall
  • node server

and voilà! it started nicely. iframely running

No idea why iframely do not start with ‘docker-compose up -d’. Note that the config file lemmy.cat is using is exactly equal to Lemmy Docker installation instructions one

Support / questions about Lemmy.
!lemmy_support

    Feel free to ask me anything here.

    • 0 users online
    • 2 users / day
    • 6 users / week
    • 17 users / month
    • 89 users / 6 months
    • 359 subscribers
    • 239 Posts
    • 1368 Comments
    • Discussion
    • Modlog