PLEASE is there a way to ONLY see SUBSCRIBED communities on my front page? I’m CONSTANTLY seeing stuff from communities I’d actually rather like to block and I’d just like it to not be included by default.

Dessalines
admin
725d

I finally figured this one out. It had to do with promise fighting. Should be fixed in v0.8.3

Great, I hope it comes out soon.
Maybe friday?

Dessalines
admin
224d

Its out now, it should be fixed in v0.8.3

Dessalines
admin
625d

There’s an issue on github but its not giving me a way to replicate this bug. When I try changing my default view to subscribed, then refresh the page, its only showing me my subscribed communities.

Could it be something strictly related to each user’s browser behaviour?

Yesterday I said i wasn’t suffering from the bug, but this morning, after updating firefox, I immediately got it.

Dessalines
admin
725d

I figured it out, it had to do with a race condition, it’ll be fixed in the next update.

Travis Skaalgard
creator
325d

It seems to happen to me after forgetting about it for a while. When I change the settings, it works right, but then after a while the bug shows up.

Dessalines
admin
225d

I’ll investigate further, and try to figure out a way to replicate it.

@k_o_t
31M

while i agree that it’s annoying to see posts from communities that you otherwise wouldn’t want to see posts from, thanks to this bug/feature i’ve discovered a ton of cool communities, that i otherwise wouldn’t have discovered, plus it helps newer communities to get more users, so it would be cool to leave this as default for all users, but give people an option to turn it off, thanks :)

Travis Skaalgard
creator
31M

Then I should be able to block certain communities.

Have you tried switching the second switch in the top from “all” to “subscribed”?
It should do the trick.

edit: duplicated word, and cleaning.

@Echedenyan
81M

Sometimes I have to change to “all” and to “subscribed” again because in every browser I try by default after log in or just when I open it in a day and, even with the option in “subscribed”, all communities are showed by default.

First time log in in every browser I have the same issue but with the theme, then I have to change from “darkly” to “default” and then to “darkly” again to put the dark theme instead of the white one.

riccardo
31M

I have the same issue

At this point, it looks like a bug in the frontend (i mean, almost without hesitation).

Travis Skaalgard
creator
21M

I’ve tried. It doesn’t change it.

That’s awkward, it works for me.
I’m gonna ask something you probably have already tried, but, have you attmpted force-refreshing the page?

@seahorse
21M

I’ve noticed this on multiple machines I use. The subscribed option has always showed the most recent posts site-wide.

Travis Skaalgard
creator
21M

I have now and it seems to be working right now? It seems very finicky.

Don’t know, maybe the browser was just high on ram ( /s ).
Keep an eye on it, it may be a bug that slipped under the dev’s nose.

A loosely moderated place to ask open ended questions

If your post is

  1. Open ended
  2. Not offensive

it’s welcome here!