After update, the avatars aren’t loading. Did the current update, rebooted, avatars not loading.

@nutomic
admin
210M

You need to run the migration script that @ksynwa mentioned, then reload the website and logout/login.

@ksynwa
110M

is it for your own instance? maybe you need to run the migration script located at lemmy/docker/prod/migrate-pictshare-to-pictrs.bash

@phelix001
creator
210M

Do I run that locally or on the server? And if on the server, should I have gitpulled everything on the server? I used ansible to install.

@phelix001
creator
110M

When using the ansible isntructions, on the server I keep getting: ./migrate-pictshare-to-pictrs.bash Restarting docker-compose, making sure that pictrs is started and pictshare is removed lemmy_postfix_1 is up-to-date lemmy_iframely_1 is up-to-date lemmy_postgres_1 is up-to-date Starting lemmy_pictrs_1 … Starting lemmy_pictrs_1 … error

ERROR: for lemmy_pictrs_1 Cannot start service pictrs: driver failed programming external connectivity on endpoint lemmy_pictrs_1 (abdbecd1d7b61c021ece9d2b963f3bb519f16e4e7c76d8a69071b6638d703550): Bind for 127.0.0.1:8537 failed: port is already allocated

ERROR: for pictrs Cannot start service pictrs: driver failed programming external connectivity on endpoint lemmy_pictrs_1 (abdbecd1d7b61c021ece9d2b963f3bb519f16e4e7c76d8a69071b6638d703550): Bind for 127.0.0.1:8537 failed: port is already allocated ERROR: Encountered errors while bringing up the project.

Do I have to kill a service?

Dessalines
mod
admin
110M

You didn’t run that script unfortunately and follow the upgrade instructions, I’m not sure how to recover exactly.

sudo docker-compose down --remove-orphans
sudo docker stop lemmy_pictshare_1
sudo docker-compose up -d
@phelix001
creator
1
edit-2
10M

Not complaining, but where would I have found the upgrade instructions? The only link I see is the one you sent me. 2, after ansible install and update, there is no lemmy folder on the server when I ssh in. So I git cloned the lemmygit onto the server, and then had to move the script into the /docker/dev folder in order for the docker-compose.yml to be available.

I have a 2nd install that doesn’t have the issues I mentioned in previous posts. After doing the above on the 2nd install, I ran the script and it gets stuck.

… sudo ./migrate-pictshare-to-pictrs.bash Restarting docker-compose, making sure that pictrs is started and pictshare is removed Creating network “dev_default” with the default driver Pulling pictrs (asonix/pictrs:v0.1.13-r0)… v0.1.13-r0: Pulling from asonix/pictrs a4a2a29f9ba4: Pull complete 127c9761dcba: Pull complete d13bf203e905: Pull complete 4039240d2e0b: Pull complete 6bb8c3967963: Pull complete b074d8e8737a: Pull complete 242df17d13ad: Pull complete Digest: sha256:73b0fb9db8a9c7916d6402a6fe0454da10f71dec47d37bee730d59ecfcea8573 Status: Downloaded newer image for asonix/pictrs:v0.1.13-r0 Building lemmy Step 1/36 : FROM node:10-jessie as node 10-jessie: Pulling from library/node 0cd7281e66ed: Pull complete 041e5427efd7: Pull complete 43cd1bce0fad: Pull complete 0c37abb5d843: Pull complete 681306f6c08e: Pull complete 49d723ca9776: Pull complete ff70586d6f75: Pull complete 2931cc91e9e5: Pull complete Digest: sha256:2f604ec6b1e755a9dc8d9864be3659e48c51d02f50ba22f720789c8d8dadd856 Status: Downloaded newer image for node:10-jessie —> 78e8f43376b4 Step 2/36 : WORKDIR /app/ui —> Running in e2cea509330c Removing intermediate container e2cea509330c —> 09ae91ed8521 Step 3/36 : COPY ui/package.json ui/yarn.lock ./ —> 4766fa7f6a76 Step 4/36 : RUN yarn install --pure-lockfile —> Running in 58a737720014 yarn install v1.22.4 [1/5] Validating package.json… [2/5] Resolving packages… [3/5] Fetching packages… info fsevents@1.2.11: The platform “linux” is incompatible with this module. info “fsevents@1.2.11” is an optional dependency and failed compatibility check. Excluding it from installation. info fsevents@2.1.3: The platform “linux” is incompatible with this module. info “fsevents@2.1.3” is an optional dependency and failed compatibility check. Excluding it from installation. [4/5] Linking dependencies… warning " > inferno-router@7.4.2" has unmet peer dependency “history@^4.10.1”. warning " > inferno-router@7.4.2" has unmet peer dependency “path-to-regexp-es6@1.7.0”. [5/5] Building fresh packages… Done in 52.81s.

Removing intermediate container 58a737720014 —> 8c821421a73c Step 5/36 : COPY ui /app/ui —> f17be2286757 Step 6/36 : RUN yarn build —> Running in 8c14a078da69 yarn run v1.22.4 $ node generate_translations.js $ node fuse prod [19:27:57] Starting ‘prod’ [19:27:57] Starting ‘clean’ [19:27:57] Resolved ‘clean’ after 5ms [19:27:57] Starting ‘env’ [19:27:57] Resolved ‘env’ after 0ms [19:27:57] Starting ‘config’ [19:27:57] Resolved ‘config’ after 5ms [19:27:57] Starting ‘copy-assets’ →Copy to dist/ — FuseBox 3.7.1 — [19:27:57] Resolved ‘copy-assets’ after 45ms → Typescript config file: /tsconfig.json → Typescript script target: ES2016

STUCK- hasn’t moved from here in 10 minutes. …

@phelix001
creator
110M

It worked last week, and I’ve only just updated it today…Do you think the migration script is the right answer?

@ksynwa
110M

i can’t say for sure. how are you deploying your instance? is it via docker or something else?

@phelix001
creator
110M

Ansible

@ksynwa
110M

maybe check if your nginx.conf has this in it:

# Redirect pictshare images to pictrs
location ~ /pictshare/(.*)$ {
    return 301 /pictrs/image/$1;
}
@phelix001
creator
110M

It doesn’t have that, and when I added it within the last } it stopped working.

@ksynwa
110M

You should probably look at https://github.com/LemmyNet/lemmy/blob/master/ansible/templates/nginx.conf to see where it goes

@phelix001
creator
110M

It apparently had all that in sites-enabled.

My ngingx error log is showing 2020/06/29 15:28:31 [error] 1104#1104: *4 connect() failed (111: Connection refused) while connecting to upstream, client: 98.111.105.126, server: .org, request: “GET /pictrs/image/pl5e3c.png/pictrs/image/thumbnail96undefined HTTP/2.0”, upstream: “http://0.0.0.0:8537/image/pl5e3c.png/pictrs/image/thumbnail96undefined”, host: “.org”, referrer: “https://.org/”

@ksynwa
110M

sorry i am not sure about this. hopefully someone else can help you out.

Support / questions about Lemmy.
!lemmy_support

    Feel free to ask me anything here.

    • 0 users online
    • 1 user / day
    • 9 users / week
    • 18 users / month
    • 92 users / 6 months
    • 405 subscribers
    • 251 Posts
    • 1394 Comments
    • Modlog